Announcement

Collapse
No announcement yet.

material wrapper as shadow sampler in alpha

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • material wrapper as shadow sampler in alpha

    Hello there.
    I use the material wrapper for a matte surface sampling shadows and reflections only. Like photo canvas with shadows and reflections but transparent. Settings: affect alpha and alpha contribution -1..., rendered with the bucket method. The quality of the shadows is very poor though. The rendered image (RGB) looks fantastic, no noise anywhere but alpha only...

    AO pass is just perfect, shadow pass as well... I use the shadow pass as reference only. I don't compose the passes in post...

    Is there a way how to control the sampling amount on the wrapper only?

    Btw. the alpha pass looks in the vray buffer great while rendering with the progressive method.
    Thx for the any hint.

    Kind regards.

    EDIT: the alpha is much much clearer rendering with the progressive method. 2,5k image, rendered for 25min.
    Last edited by o-v; 29-01-2018, 06:53 AM.

  • #2
    Can you attach an example scene with that issue?
    Zdravko Keremidchiev
    Technical Support Representative

    Chaos Group

    Comment


    • #3
      Duh... NDA... would have to build something from scratch.

      Comment


      • #4
        You can build something very simple as soon as you can reproduce the issue with it. Or you can dramatically strip your scene. Also If you don't want to share it here you can send it to support@chaosgroup.com
        Zdravko Keremidchiev
        Technical Support Representative

        Chaos Group

        Comment


        • #5
          Roger, as soon as I can, I'll report.

          Comment


          • #6
            Here it is:
            http://www18.zippyshare.com/v/ijBITBFh/file.html

            Even the beauty is fine and with denoiser perfect for my needs in respect to rendertime, the alpha is very noisy though.

            Thx in advance.

            Comment


            • #7
              You could go into the VRay settings of the shadow catching object and increase its "Subdivs multiplier".

              Comment


              • #8
                THX I'll give it a try...
                EDIT: Went up to 100 - no effect. Which is sort of obvious. I don't see here the connection to the number of samples. The one, that could work, is tweaking the light.... will report.
                EDIT 2: Denoiser seems to ignore the wrapper material ... It has no effect, or at least for me, on the noise in alpha

                Nope - changing texture samples on the dome light - I use a dome light with a hdri btw. - does not affect the alpha noise. And even with a noise threshold of 0.005 in the bucket image sampler, it's noisy. Less noise, but too much for my likin'.
                Last edited by o-v; 30-01-2018, 01:24 AM.

                Comment


                • #9
                  Thank you for providing the scene. According to my rendering the shadow noise levels are identical in both cases (the RGB without matte and in the Alpha with matte). The alpha might look grainier because of the black background.
                  Comparison.jpg
                  Keep in mind that the dome light scatters the lights in all directions so it needs more sampling in order to generate smoother shadow. Therefore you might need to decrease the noise threshold even more.
                  Zdravko Keremidchiev
                  Technical Support Representative

                  Chaos Group

                  Comment


                  • #10
                    Lower than 0.005? Hmmm that makes the game a little harder. Can you confirm denoiser havin' no effect on the wrapper?

                    Comment


                    • #11
                      You can denoise the Alpha element in the standalone Denoiser tool. Make sure to denoise the 'RGB with all elements (including the alpha) at once rather then the Alpha alone.
                      Meanwhile I'll make a note to include a denoise option for the Alpha render element.
                      Zdravko Keremidchiev
                      Technical Support Representative

                      Chaos Group

                      Comment


                      • #12
                        Thank you very much!

                        Comment


                        • #13
                          An update: We decided to denoise the alpha automatically with the RGB without adding an option.
                          For the denoiser tool, if the elements to be denoised are specified with the -denoiseElements option or the GUI, the alpha is not denoised automatically, only if it's selected (just like before). Otherwise, if the elements are not specified, the alpha will be denoised automatically.
                          Zdravko Keremidchiev
                          Technical Support Representative

                          Chaos Group

                          Comment


                          • #14
                            What version of Vray do I need to get the new denoiser defaults? I have 3.60.04 installed and I have similar issues with noise in the alpha (matte).

                            Comment


                            • #15
                              I guess you have to wait for Next or crank down the threshold...

                              Comment

                              Working...
                              X