Announcement

Collapse
No announcement yet.

Projection textures in GPU

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Projection textures in GPU

    Is there any chance we can get this working in Maya GPU ? It's an invaluable tool in so many circumstances. I'm just asking in case it's an easy thing that's been overlooked.

  • #2
    Texture projection is supported in Perspective and Planar modes on the GPU rendering.
    Do you need other modes or if it something else can you provide more information?
    Thank you very much in advance.
    Last edited by svetlozar.draganov; 22-02-2018, 06:01 AM.
    Svetlozar Draganov

    Technical Support Representative
    support@chaosgroup.com

    Chaos Group

    Comment


    • #3
      Thank you Svetlozar. I must be taking the wrong approach then. Generally Maya >File (create as 2D projection) This works fine in CPU but not GPU at my end

      Super simple setup eg:

      ProjFileHyperShade.jpg


      Comment


      • #4
        Yes, I can confirm that this setup works fine with GPU rendering if projection type is Planar or Perspective.
        This is true for the latest official 3.60.03.
        Can you send me the scene, even though it is very simple and let me know the versions of V-Ray, Maya and OS that you are using?
        Svetlozar Draganov

        Technical Support Representative
        support@chaosgroup.com

        Chaos Group

        Comment


        • #5
          AHHH! Got to the root of it ! - It does work fine as you say, as long as the 2D texture to be projected is a file. If a ramp is used for the 2D texture it doesn't work in GPU, but does work in CPU.

          I wouldn't have thought to check that without your feedback, thank you ! - I'll just replace all ramps in my scenes with gradient textures instead.


          You guys are outstanding with the support

          Comment


          • #6
            You are correct, there is something wrong with the projection of the Ramp texture, will make a note about it into our system and will update the thread when we have a fix about it.
            Svetlozar Draganov

            Technical Support Representative
            support@chaosgroup.com

            Chaos Group

            Comment


            • #7
              It's been a couple of months, so just popping a rude little nudge in here...

              Comment


              • #8
                It is being reported as bug VGPU-3071 with "critical" priority, but so far we haven't looked at it. Sorry for the delay.

                Best,
                Blago.
                V-Ray GPU Lead Developer | blagovest.taskov@chaosgroup.com
                Facebook Fan Group

                Comment


                • #9
                  Oh no stress in that case! .. was just double checking to see it hadn't been missed. Thank you

                  Comment


                  • #10
                    Originally posted by ricoholmes View Post
                    Oh no stress in that case! .. was just double checking to see it hadn't been missed. Thank you
                    We have fixed that internally. As soon as there are nightlies/beta, it should work fine.
                    Thanks for the report and sorry for the troubles.

                    Best,
                    Blago.
                    V-Ray GPU Lead Developer | blagovest.taskov@chaosgroup.com
                    Facebook Fan Group

                    Comment


                    • #11
                      Outstanding, as always! Thank you

                      Comment

                      Working...
                      X